Grid Sage Forums

Grid Sage Forums

  • April 23, 2024, 08:01:34 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

LINKS: Website | Steam | Wiki

Author Topic: ans export not working?  (Read 1072 times)

nitrofurano

  • Unaware
  • *
  • Posts: 4
    • View Profile
ans export not working?
« on: November 03, 2021, 02:15:37 PM »

hi!
as battleofthebits has .ans format battle, and both Moebius and PabloDraw aren't that intuitive as RexPaint, i gave RexPaint-Ansi a try
the problem is that i couldn't export to .ans (or at least i have no idea to where it got exported?)
i'm using the last version 1.60 on GNU/Linux via Wine (Ubuntu 21.10, Wine 5.0.3)
thanks in advance, and cheers!
« Last Edit: November 03, 2021, 04:35:52 PM by nitrofurano »
Logged

Kyzrati

  • Administrator
  • True Cogmind
  • *****
  • Posts: 4304
    • View Profile
    • Cogmind
Re: ans export not working?
« Reply #1 on: November 03, 2021, 04:42:45 PM »

Hi nitrofurano! Wow it's been years since I saw you :) (AtariAge)

.ans exporting definitely works fine, so you must be doing something wrong there.

Are you sure you...
1) are using the ANSI version of REXPaint? (or reconfigured the normal version for .ans export)
2) read the Appendix D of the manual which describes all about ANSI art and .ans exporting?
3) are using the ctrl-a hotkey to export the .ans file

In particular the manual will probably cover whatever it is you're missing if it's not already in the list above.
Logged
Josh Ge, Developer - Dev Blog | @GridSageGames | Patreon

nitrofurano

  • Unaware
  • *
  • Posts: 4
    • View Profile
Re: ans export not working?
« Reply #2 on: November 04, 2021, 05:57:38 AM »

hi Kyzrati!

yes, long time i'm not around atariage forum (and long time i'm not coding anything to colecovision as well, shame on me! :D )

about all these steps you mentioned, i did all of them (except reconfiguring normal version for .ans export) - i think i also read all the documentation - so how and where should i start troubleshooting? i also have no idea where the .ans gets saved when it works, as i found nothing after searching for all attempts everywhere...

( and talking about the .ans i submitted to battleofthebits, i made these on Moebius/PabloDraw: https://battleofthebits.org/arena/Entry/zanzare+dell%E2%80%99estate/47207/ - https://battleofthebits.org/arena/Entry/z/44627/ - so i guess you can imagine how painful and tedious was making them on these tools, and how more comfortable would be making them on RexPaint! ;)  (and imagine also how many people will love to use RexPaint on .ans submissions there! ;) )  )

thanks and cheers!
« Last Edit: November 04, 2021, 06:03:04 AM by nitrofurano »
Logged

Kyzrati

  • Administrator
  • True Cogmind
  • *****
  • Posts: 4304
    • View Profile
    • Cogmind
Re: ans export not working?
« Reply #3 on: November 04, 2021, 06:32:00 AM »

I mean when you asked (since I don't use .ans myself--just added it for the convenience of others like yourself), just to be absolutely certain I simply downloaded ANSI version from the REXPaint website, unzipped it, quickly drew some glyphs on the default image and hit Ctrl-a to export, which displays the message "Exported images/unnamed.ans," indicating where the file was exported to. Open up REXPaint's /images/ directory and there's the .ans file as expected...

So first of all, I guess you'd have to list your steps and how they and the results are different from what I described above. I would recommend doing the exact steps I just mentioned, rather than working with whatever copy/version you're using right now. In a general sense, troubleshooting is about simplifying a process down to its most basic roots then gradually adding on extra complexities while checking to make sure everything's still working as expected with each addition. One of the things you're doing differently is affecting the results.

so i guess you can imagine how painful and tedious was making them on these tools, and how more comfortable would be making them on RexPaint! ;)  (and imagine also how many people will love to use RexPaint on .ans submissions there! ;) )  )
For me I definitely prefer REXPaint workflow, but as one might expect, people used to those older tools actually still like them. Funny thing that just yesterday I saw someone mention that they love the extra features of REXPaint, but would prefer it have the workflow from PabloDraw since it's what they are familiar with xD

Nice work, btw, and I can imagine at least the first one would be much quicker to do in REXPaint by comparison :P
Logged
Josh Ge, Developer - Dev Blog | @GridSageGames | Patreon

nitrofurano

  • Unaware
  • *
  • Posts: 4
    • View Profile
Re: ans export not working?
« Reply #4 on: November 05, 2021, 07:43:45 AM »

so let's see:
1- downloaded from https://www.gridsagegames.com/rexpaint/downloads.html - https://www.gridsagegames.com/blogs/fileDownload.php?fileName=REXPaint-v1.60-ANSI.zip
2- extracted the downloaded file
3- opened REXPaint.exe on wine (right click, from context menu)
4- REXPaint opened fine
5- drawin some stuff
6- pressed ctrl-a - and no message like "Exported images/unnamed.ans," appeared anywhere, not on the middle, neither on top or bottom
7- clicked on the "Export" "button" (left side of the toolbox) - nothing happened again
8- checking ./images directory (that subdirectory where REXPaint.exe is) - empty...
9- tried to save by pressing ctrl+s - a save message appeared in the middle asking for a file name, but nothing got saved at ./images directory and nowhere else (supposedly)

so i guess it might be something related to wine somehow?
perhaps i needed to open REXPaint.exe from wine from a terminal command line instead, and some error messages might appear from there?
Logged

nitrofurano

  • Unaware
  • *
  • Posts: 4
    • View Profile
Re: ans export not working?
« Reply #5 on: November 05, 2021, 07:47:02 AM »

tried now to open from wine from terminal - no error messages appeared and now it got exported to .ans format at ./images - i wonder why it only exports when wine is being run from terminal, or why it sometimes work and sometimes doesn't - weird...
Logged

Kyzrati

  • Administrator
  • True Cogmind
  • *****
  • Posts: 4304
    • View Profile
    • Cogmind
Re: ans export not working?
« Reply #6 on: November 05, 2021, 08:20:12 AM »

Yep, that makes sense now, you've encountered some kind of Wine issue that is blocking REXPaint from creating certain files for some reason. Likely a permissions thing. Could also be an antivirus thing, although I'm not sure if that would still take effect within the Wine environment itself--depends on what you've got set up.
Logged
Josh Ge, Developer - Dev Blog | @GridSageGames | Patreon