Grid Sage Forums

Grid Sage Forums

  • November 21, 2017, 03:10:53 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

LINKS: Website | Steam | Wiki

Pages: 1 [2]

Author Topic: Running on Linux with Wine seems to work fine [SOLUTIONS INSIDE]  (Read 5867 times)

Kyzrati

  • Administrator
  • True Cogmind
  • *****
  • Posts: 2626
    • View Profile
    • Cogmind
Re: Running on Linux with Wine seems to work fine [SOLUTIONS INSIDE]
« Reply #25 on: June 26, 2017, 07:11:05 PM »

Many thanks for the tip!
Logged
Josh Ge, Developer - Dev Blog | @GridSageGames

Joshua

  • Derelict
  • **
  • Shared a Confirmed Combat Win Shared a Confirmed Stealth Win
  • Posts: 23
    • View Profile
Re: Running on Linux with Wine seems to work fine [SOLUTIONS INSIDE]
« Reply #26 on: September 23, 2017, 05:58:05 AM »

I think this is worth a mention. Cogmind bugs affecting only Linux do get fixed.

For anyone else running Debian Jessie or an old version of Wine: I ran into this item description display bug also, on Cogmind beta 2.1, with Wine 1.6.2. Updating to Wine 1.8.7 from the backports archive appears to have fixed it.

My experience running Cogmind on Linux has otherwise been flawless, exactly as advertised, once I got the 32-bit version of Wine and Mono installed.
Logged

chameleon

  • Unaware
  • *
  • Posts: 2
    • View Profile
Re: Running on Linux with Wine seems to work fine [SOLUTIONS INSIDE]
« Reply #27 on: October 18, 2017, 01:56:57 PM »

Hi

I am running Cogmind on Opensuse Leap 42.3 64bits with Wine 2.0 and don't have sound. Here's the trace when running Cogmind:

Code: [Select]
wine COGMIND.exe
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.VC80.CRT" (8.0.50727.762)
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x32d88c 1 C) semi-stub
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x32d68c 1 C) semi-stub
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x32d53c 1 C) semi-stub
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x32d46c 1 C) semi-stub
fixme:keyboard:X11DRV_LoadKeyboardLayout L"00000409", 0080: semi-stub! Returning default layout.
fixme:keyboard:X11DRV_LoadKeyboardLayout L"00000409", 0001: semi-stub! Returning default layout.
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x5c7cedc 1 C) semi-stub
fixme:msvcrt:__clean_type_info_names_internal (0x34d564) stub
fixme:msvcrt:__clean_type_info_names_internal (0x1001b34c) stub

No reference to sound at all. When I try the test sound in winecfg it does work. Should I run the game from a 32 bits wine prefix maybe? I also installed the mono-core package.
Logged

Raine

  • Unaware
  • *
  • Weekly Seed Participant
  • Posts: 17
    • View Profile
Re: Running on Linux with Wine seems to work fine [SOLUTIONS INSIDE]
« Reply #28 on: October 19, 2017, 08:40:42 AM »

https://wiki.archlinux.org/index.php/wine

IME using 32-bit WINEPREFIX and WINEARCH are much more likely to get things running smoothly. I had a number a programs I had issues with until I did this. I believe I had to use winetricks as well for certain things. I've only used debian and arch based distros so I can't help with any tips that might be related to the way SUSE does things.
Logged

Tchey

  • Unaware
  • *
  • Posts: 1
    • View Profile
Re: Running on Linux with Wine seems to work fine [SOLUTIONS INSIDE]
« Reply #29 on: October 19, 2017, 08:41:05 AM »

Hi, i just saw a message on twitter, so i came, but i'm useless.

Linux Mint here,

I'm playing with Steam version, under PlayOnLinux, and i don't have any trouble. When i was playing out of Steam, it was also running very well.

Sorry i cannot help, i don't know much about Linux issues, i'm just a more or less basic user, i can only share my (positive) experience.
Logged

chameleon

  • Unaware
  • *
  • Posts: 2
    • View Profile
Re: Running on Linux with Wine seems to work fine [SOLUTIONS INSIDE]
« Reply #30 on: October 21, 2017, 08:55:12 AM »

i just tried to set up the game with wine and also didn't get any audio. in my case, there seemed to be a conflict between system and wine SDL audio libraries (see 'SDL applications' section of https://wiki.winehq.org/Sound).

i was able to fix it by launching the game with:
Code: [Select]
env SDL_AUDIODRIVER="" wine ./COGMIND.exe
this was the only issue i had. everything else is working fine without any further config.
(opensuse tumbleweed, using wine 2.11)

Yes! Updating to the latest wine (by adding the relevant repository: http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_Leap_42.3/) creating a 32bit prefix and using the above command (setting sdl_audiodriver to nothing) worked!
Logged

TLW

  • Unaware
  • *
  • Posts: 1
    • View Profile
Re: Running on Linux with Wine seems to work fine [SOLUTIONS INSIDE]
« Reply #31 on: October 29, 2017, 01:43:46 PM »

I can confirm that the game "just works". Debian Stretch, wine 2.17 staging. As others have mentioned, alt-tab dies, though.

I think this is worth a mention. Cogmind bugs affecting only Linux do get fixed.

As an FYI, I would not have bought the game without this.
Logged
Pages: 1 [2]